Page Contents ×

This page offers starting points for work with Project Lavina.

 

Open a .vrscene


A .vrscene file can be opened in Project Lavina in one of two ways:

FIle > Open Scene > Select the .vrscene;

or you can drag-n-drop the .vrscene file directly into Project Lavina and it automatically renders the scene.


Navigation


A full list of hotkeys are found in Help tab > Mouse and Key shortcuts.

Hold the middle mouse button to move the camera sideways (dolly).

To orbit, hold the Alt key and drag with the middle mouse button.

Ctrl+Alt+middle mouse button lets you smooth zoom in and out. You can also scroll the mouse wheel to zoom in/out.

In Free look mode, you can use the W, A, S and D keys to navigate in the scene. Press the F2 to exit the mode.

The E and Q keys move the camera up and down.

 

 


Loading Assets

You can drag-n-drop any supported file directly into Project Lavina to load it.

When loading a scene, if the assets (textures, proxies) are missing from their original paths or the scene folder, Project Lavina looks for them next to where the .vrscene file is in a folder that has one of the following names:

assets, maps, proxy, textures, vray_proxy


LUT and HDRI


LUT files can be loaded from the Post tab in Project Lavina.

Clicking on the current LUT file shows a list of recently used LUT files and also lists all LUT files in the same folder as the currently loaded LUT.

HDRI maps can be loaded from the Load Environment button. Click on the currently loaded HDRI to show a list of recently used HDRI maps and a list of all HDRI maps in the same folder.

You can rotate the environment from the Rotation option and adjust the intensity using the Intensity option.

 


Objects


If a scene is being rendered and you drag-n-drop a .vrmesh or .vrscene file you can choose to Merge the new asset with the currently opened scene or Open the new file.

This example merges a few .vrscene files and adds a .vrmesh file and assigns a material from the scene to the .vrmesh.

In addition, you can rotate, scale and move each object around. First enter the Selection mode by pressing the selection () button (or hotkey Q). Select the object and press W for moving, E for rotation and R for scale. Press the Q key to go back to selection.

You can also hide/unhide any object from the Objects tab.

The Materials tab can be used to assign any material to the selected object using the Assign to Selection button.

Configuration (.vrdx) Files


Once you make changes to your scene, you can save them as a configuration .vrdx file for later use.

Go to File > Save scene config file and save the .vrdx file.

In this example, we show two interior light configurations - one for daylight and one for night/dusk light, that we save and then compare.

We use LUT files to enhance the lighting and tweak the lights' intensity and color to match a day or night feel for the scene.

Save scene config file option saves a .vrdx file with the name of the scene by default. This configuration file is always loaded with the scene.

The Save scene config file as... option allows you to save a .vrdx file with a different name and load it when needed.

 

 


Cameras


When loading a scene in Project Lavina, the default camera stored in the .vrscene file is used.

Navigating through the scene, you can save many camera views and go back to them when needed.

Press the Save New Camera Slot button in the upper right corner (). A new camera slot from the current view is created, which you can rename.

Another way to save a camera is to select an Empty slot and hold the Save Camera button for the drop-down menu to appear. Select the Save This Cam Slot - it saves the currently selected camera view. Then you can rename it.

You can always go back to the camera that comes from the .vrscene file by selecting Home from the drop-down.


Offline Render


You can render a high quality snapshot from the current view. Go to Tools > Render a High Quality Snapshot. In the pop-up window you can select the resolution and the Samples for the render. The more Samples you use, the better the quality of the render, but at the cost of render time.

You can also enable the Save as defaults option to set the current output settings as your default.

Choose the output directory, name and format.

When the render is in progress you can Stop and save the frame the quality is sufficient, or Pause, or Abort the render.


Recording a Walkthrough


To start recording a walkthrough, go to the Tools tab > Record a walkthrough or from the record button on the bottom right ().

Enter Free look mode. The walkthrough is recorded while you walk around. You can stop the recording from the same button ().

Then, you can render the walkthrough by going to Tools > Render High Quality Walkthrough or from the teapot render icon (). Choose the render resolution and press Start. You are prompted to select the output directory and file name.