This page gives some details on what hardware and operating systems are required for V-Ray to work properly.

Page Contents ×

Windows


Please make sure that your system fulfills these requirements before installing V-Ray. Note that V-Ray is only supported for 64 bit operating systems and 64 bit versions of Maya.

Processor

1st Gen Intel® Core™ or compatible processor with SSE4.2 support (x64)

RAM

4 GB RAM and 4 GB swap minimum – recommended 8 GB or more RAM, 8 GB or more swap file;

(Actual amount required will vary with scene requirements.)

USB PortRequired for customers using legacy hardware lock, preferably USB 2.0
TCP/IPOnly IPv4 required for distributed rendering is supported. IPv6 is currently not supported
GPU Acceleration

NVIDIA CUDA: Maxwell-, Pascal-, Volta- and Turing-based NVIDIA card(s) with with latest recommended video driver or at least version 441.20;

NVIDIA RTX: RTX cards with latest recommended video driver or at least version 441.28;

V-Ray Production Denoiser: AMD or NVIDIA GPU supporting OpenCL 1.2;

NVIDIA AI Denoiser: Maxwell, Pascal, Volta or Turing-based NVIDIA card with latest recommended video driver or at least version 441.20



The following table shows the versions of Autodesk Maya and operating systems on which V-Ray is supported. Note that V-Ray is only supported for 64 bit operating systems and 64 bit versions of Maya.

Version of Maya Supported Operating System
Maya 2016Windows ® 7 SP1, Windows ® 8.1 Professional, and  Windows ® 10 Professional
Maya 2017Windows ® 7 SP1, Windows ® 8.1 and Windows ® 10 Professional
Maya 2018Windows ® 7 SP1, Windows ® 8.1 and Windows ® 10 Professional
Maya 2019Windows ® 7 SP1, Windows ® 8.1 and Windows ® 10 Professional

 

 

 

 

Linux


Please make sure that your system fulfills these requirements before installing V-Ray.

Processor

1st Gen Intel® Core™ or compatible processor with SSE4.2 support (x64)

RAM

4 GB RAM and 4 GB swap minimum – recommended 8 GB or more RAM, 8 GB or more swap file

USB PortRequired for hardware lock, preferably USB 2.0
TCP/IPOnly IPv4 is supported. IPv6 is currently not supported
GPU Support

NVIDIA CUDA: Maxwell-, Pascal-, Volta- and Turing-based NVIDIA card(s) with latest recommended video driver or at least 410.48;

NVIDIA RTX: RTX cards with latest recommended video driver or at least version 440.36

V-Ray Production Denoiser: AMD or NVIDIA GPU supporting OpenCL 1.2; 

NVIDIA AI Denoiser: Maxwell, Pascal, Volta or Turing-based NVIDIA card with latest recommended video driver or at least 410.48

 

 

 



The following table shows the versions of Autodesk Maya and operating systems on which V-Ray is supported. Note that V-Ray is only supported for 64 bit operating systems and 64 bit versions of Maya.

Version of Maya Supported Operating System
Maya 2016Red Hat ® Enterprise Linux® 6.5 WS, or CentOS 6.5
Maya 2017Red Hat ® Enterprise Linux® 6.5 and 7.2 WS, or CentOS 6.5 and 7.2
Maya 2018Red Hat ® Enterprise Linux® 6.5 and 7.2 WS, or CentOS 6.5 and 7.2
Maya 2019Red Hat ®  Enterprise Linux® 6.5 and 7.2 WS, or CentOS 7.2

Mac OS X


Please make sure that your system fulfills these requirements before installing V-Ray.

Processor

1st Gen Intel® Core™ or compatible processor with SSE4.2 support (x64)

RAM

4 GB RAM and 4 GB swap minimum – recommended 8 GB or more RAM, 8 GB or more swap file

USB PortRequired for hardware lock, preferably USB 2.0
TCP/IPOnly IPv4 is supported. IPv6 is currently not supported

 

 

 V-Ray GPU works only with C++/CPU devices under macOS. V-Ray GPU can still be used in distributed rendering where a macOS machine runs the CUDA engine on a CPU device together with Windows/Linux machine(s) running CUDA engine on GPU device(s).

 

 

The following table shows the versions of Autodesk Maya and operating systems on which V-Ray is supported. Note that V-Ray is only supported for 64 bit operating systems and 64 bit versions of Maya. 

Version of Maya

Supported Operating Systems

Maya 2016.5Apple ® Mac OS ® X 10.14, 10.13, 10.12, 10.9.5, 10.10.x, and 10.11.3
Maya 2017Apple ® Mac OS ® X 10.14, 10.13, 10.12, 10.10.5 and 10.11.x
Maya 2018Apple ® Mac OS ® X 10.14, 10.13, 10.12, 10.10.5 and 10.11.x
Maya 2019Apple ® Mac OS ® X 10.14, 10.13, 10.12 and 10.11.x

 

 

* The Autodesk Maya system requirements can be found here page: http://knowledge.autodesk.com/support/maya/troubleshooting/caas/sfdcarticles/sfdcarticles/System-requirements-for-Autodesk-Maya.html