This page provides a step-by-step tutorial on how to composite Render Channels in an image editor, in this case Adobe Photoshop, for flexibility to improve your workflow.


Page Contents

 

Introduction


In this tutorial we’ll go over how to adjust specific components of a rendered image to give you better control over the final quality of your output.

To follow this tutorial, you will need to have the V-Ray for Revit plugin installed.

This tutorial page is a companion that goes with the QuickStart video posted on our YouTube channel and is available here:

 

 

 

 

Tutorial Assets


To download the files used in this tutorial, please click on the button below.


 

Tutorial Steps


Open the Previously Completed Render 

Start Revit and open the V-Ray Frame Buffer (VFB). We see here the VFB with the render from the last tutorial, which you can check out and download here.

 

 

 

However, if you don’t wish to go through that tutorial to generate your own render of that project, we can load the already rendered V-Ray image: In the VFB window, click the Load Image icon    

 

 

Navigate to the channels.vrimg file from the downloaded assets from this Download Project Files icon link above. This will load the beauty render as well as all its channels from the project.


 

 

The first thing to do is to save out the render channels to disk by clicking the disk icon in the VFB.  

 

 

 

For the image type, we’re going to need to use a 32-bit image format for compositing to work properly. Choose OpenEXR, and give the image a name and a location to save to, such as “compositing”; this will save out all the channels with “compositing” as the base name.

 

 

 

Working in Photoshop

Open Photoshop CC, or other image editor that allows for additive layering. To load the list of images into a single working file in Photoshop, click File > Scripts > Load Files into Stack….

 

 

 

Click Browse and select the files you want in your stack. 

 

 

 

 

We’ll be using the beauty pass (Compositing.exr) along with the individual Render Channels (AtmosphereBackgroundGlobal IlluminationLightingReflectionRefractionSelf-Illumination, and Specular.) that can combine to make up the beauty pass. Select these Channels as seen below.

 

 

 

Now with everything selected, click OK.

 

 

 

Move the RGB channel, composite.exr up to the top in the Photoshop Layers.

 

 

 

Notice that the sky area is cut out. The sky is still there, but it is being made transparent by the Alpha channel, so we just need to disable that transparency.

 

 

 

With the composite.exr still selected, go to the Layer menu in the menu bar, and select Layer Mask > From Transparency. This takes the alpha transparency and turns it into a Photoshop mask for that layer, which we will dispose of next.

 

 

 

Now, drag that mask down to the Trash icon to get rid of it.

 

 

 

Click Delete in the dialog window to confirm. You do not want to Apply the mask.

 

 

 

Now, the sky color is shown in the layer.

 

 

 

We need to repeat this procedure for the other layers. You can use this same process for each remaining layer, or you can create an Action for them to help automate the prcoess for you. We have created one already that you can load into Photoshop:  Click on Window > Actions to turn on the Actions window, if it is not already displayed.

 

 

 

Then, click as shown below.  

 

 

 

Select Load Actions.

 

 

 

Navigate to the downloaded assets for this tutorial and select the file Photoshop_remove_alpha.atn.

 

 

Now all you need to do is select each respective layer, and then select Remove Alpha in the Actions and click play,as seen below.

 

 

 

Repeat for any remaining layers.

 

 

 

Layering in Photoshop

Now our task at hand is to properly layer all these images together to re-form the beauty or RGB render. 

Hide the “compositing.exr” layer. 

 

 

Each layer needs to add color information to the layer below it, so we need to set all the layers to an additive mode. Select all the layers.

 

 

 

 

In the Layer mode drop down menu, select Linear Dodge (Add) to change them all at once. 

.

 

 

 

Each layer’s color information is now adding to the layers below, which gives us the beauty pass. Compare with the composite.exr top layer, and it is the same as the stack. Now that we have this, we can start tweaking the individual layers to adjust the image. The power from compositing really comes from making slight adjustments to these layers as opposed to turning them off completely.

 

 

For example, if the Specular reflections seem too bright, you can try adjusting the opacity of that layer to reduce the specularity. Adjust it to about half.

 

 

 

Now, reduce the amount of bounced light inside the room by reducing the Opacity of the Global Illumination layer. Set this to 80% to add a little more mood in the render

 

 

 

You can also affect the coloration using an Adjustment Layer: Make sure the Global Illumination layer is still selected and select the button shown below to create a new fill or adjustment layer.

 

 

 

 

 Choose Hue/Saturation.

 

 

 

Ensure that this layer is immediately above Global Illumination layer. Click the button shown below in the Properties window to have that adjustment layer only affect the layer right below it, and not all the layers below it in the Layer stack.

 

 

 

Now you can easily remove the saturation out of just the bounced light in the scene.  Adjust the Saturation to -52. Because this is a 32-bit image, there is plenty of information in the image to adjust without a loss in quality.

 

 

 

 

You can see the results below.

 

 

 

Saving your Output

Now this image can be saved as a 32-bit exr or PSD file easily, but to output it for most uses such as an online presentation, you need a more common file format such as PNG or JPG.

 

First, you need to convert this down from a 32 bit. Click the Image menu and select Mode > 8 bits/Channel.

 

 

 

 

Click Merge. Keep in mind that by going down to 8 bits, you will lose most of your ability to edit the image's color and tone without the potential for artifacts and/or color banding. 

 

 

 

 

Once you click Merge, you will see the HDR Toning dialog. 

 

 

 

 

Here is where you instruct Photoshop on how to go down from 32-bits to 8-bits. Select Exposure and Gamma from the drop down menu. 

 

 

 

Click OK to get the same look down into 8-bit space. You can now save the image in common formats such as jpg or png.

 

 

 

As you can see, using Render Channels and image editing after a render gives you great control over your final output.