Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.
Section
bordertrue
Column
width50px50%

Table of Contents
maxLevel3
stylesquare

Column
width50px50%

Section
bordertrue
Column
width100px100%

Part I: Creating a Fly-Through Animation


Step 1. Open the scene (which can be found here).

1.1. Setup your SketchUp scene tabs. This can be done by going to View->Animation->Add Scene. Scene tabs for this file are already created for you.

 

Section
bordertrue
Column
width100px100%

Step 2. Go to Window->Model Info->Animation, and make sure that “Enable scene transitions” is checked, and set it to 20 seconds. Also make sure “Scene Delay” is set to 0. 

 

Section
bordertrue
Column
width100px100%

Step 3: Under Global switches turn on Don’t render final image. This will prevent V-ray from rendering after GI is calculated. 

 

Section
bordertrue
Column
width100px100%

Step 4. Under the Output rollout in the Animation section turn on the check box next to Animation on. This will tell V-ray to render all of the frames between scene tabs. Make sure Include Frame Number is checked. When the image sequences are saves, this option will add numbers to each image saved to create the image sequence. 

 

Section
bordertrue
Column
width100px100%

Step 5. Under Indirect Illumination, set primary bounce to Light cache and secondary bounce to None. 

 

Section
bordertrue
Column
width100px100%

Step 6. Set the Frame rate to Custom, and set FPS to 1. We are setting FPS to 1 simply for calculating the Light Cache. If this was off or set to 0, then the Light cache would only calculate for the first frame. With it set to 1 it will calculate for the entire animation. 

 

Section
bordertrue
Column
width100px100%

Step 7. Under Light cache change the Mode to Fly-through, and hit render. The Light Cache will calculate for the entire animation, then go through several iterations of according to the FPS number. 

 

Section
bordertrue
Column
width100px100%

Step 8. After Light cache is calculated, and the V-ray progress window is done, in the Light cache rollout under Current map, click Save, and choose a location and file name.

 

Section
bordertrue
Column
width100px100%

Step 9. Now switch the light cache Mode from Fly-through to From File, and on the right, choose the light cache file (vrlmap file) that we just saved. 

Step 10. Under Indirect illumination (GI), change the Primary bounces to Irradiance map and the Secondary bounces to Light cache

Step 11. Under Irradiance map change the Mode from Single frame to Incremental add to current map. This will allow the Irradiance map to simply add to the same map as it calculates along the camera path.

Step 12. Under Output change the FPS from 1 to 2, and hit render. Choosing 2 FPS in this instance will calculate the Irradiance map 40 times along our camera path based on how many scenes there are and the number of seconds between scenes. Or it can also be thought of how many frames along a camera path you want to render. 

The formula for calculating this is: 

(number of scene tabs - 1)*(seconds between scenes) *FPS = number of renderings along camera path.

In our example we have 2 scene tabs with 20 seconds of animation between tabs, and with 2 frames per second, the irradiance map will calculate 40 times along the animation. 

Step 13. Now under Irradiance map rollout, hit the Save button and choose a location and file name for the irradiance map.

Step 14. Now change the irradiance map Mode from “Incremental add to current map” to From File, and on the right choose the location of the saved irradiance map (vrmap file). 

Step 15. Under Global switches uncheck Don’t render final image.

Step 16. Now under Output check Save render output, and choose a location (preferably in a folder since it will save an image sequence) and file type. Choosing jpg is perhaps the most straightforward file format with the smallest file size. If you choose png take note that by default the sky will render as a transparency. If you would like to turn off the alpha for png, under the VFB channels rollout, simply unselect Alpha. 

Step 17. Change the FPS from 2 to 30, and now hit the render button. 
With the 20 seconds of animation at 30 FPS, it will render 600 still images. Because Include Frame Number was checked each image will save with the number according to the order it was rendered. When the animation is done you will have a folder with 600 different jpgs or pngs, depending on which file format you saved to. 

Step 18. With the image sequence created, you can use a variety of programs to stitch the sequence into a video format. Software such as Quicktime Pro and Photoshop CS5.5 and higher are capable of creating videos from image sequences.

Part II: Create a Video File using Quicktime Pro


Step 1. Open Quicktime Player

Step 2. Go to File-> Open Image Sequence

Step 3. Locate to the first file of the image sequence, then at the bottom next to Frame rate choose correct frame rate. This should be the same value as the FPS field in your Vray settings under Animation, just before rendering. Typically 30 FPS is recommended.

Step 4. Hit the Open button and wait for Quicktime to put all of the images into a sequence. At this point you can play to preview your animation.

Step 5. If you are happy with the result, to save it to a video format go to File-> Export. Under Export, choose Movie to Quicktime Movie, then hit the Options button.

Step 6. Under Video, hit the Settings button, and for Compression Type choose H.264, frame rate to Current, Key Frames to Automatic, Compressor Quality to High. Hit OK, OK, then Save. Now you have a .mov video file of your animation.

You can view the finale animation from SketchUp 2013 (which can be found here).