Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

One of the most powerful features of Pdplayer is its layered timeline workflow. Every sequence, movie clip or still image you will ever work with in Pdplayer, will be placed on a layer. To add a sequence as a layer in Pdplayer, you can do any of the following:

Fancy Bullets
typecircle
  • Go to File > Add Layer or press Ctrl + L to open the Add Layer dialog. Here you can select an image file and click Open to add it as a layer. Pdplayer will automatically detect if it is a part of a sequence, a single file, or part of a stereoscopic sequence, and create the appropriate layer type.
    • If you want to add just a single file from a sequence, enable the Add as single image option. If this option is not turned on, Pdplayer will assume the images are not part of a sequence.
    • Enabling the Position after current layer option will place the layer after the current one in the timeline.
    • If you are loading one part of a stereoscopic sequence, you can enable the Add other stereo view option to automatically add the sequence for the other view. Pdplayer will recognize recognizes keywords in the path and file name to load the correct sequence, for example the characters left in the filename to indicate the left view, and right for the right view.
  • Drag and drop a file over an open Pdplayer window. Note that if you want to add an image that is a part of a sequence as a Still Image Layer, you should hold the Ctrl key while dragging and dropping it. Holding the Shift key while dragging will place the layer current one in the timeline.
  • Double-click on a file in Windows Explorer (if it is associated with Pdplayer already).
  • Copy/paste a file from Windows Explorer. Note: If it is an image file, it will be added as a Still Image Layer.
  • Right-click in Windows Explorer and choose Open With > Pdplayer.

...

Working with layers is extremely easy. You can select a layer by clicking on it. Shift + Click and Ctrl + Click are also supported in order to select multiple layers.

The layers can also be selected by Group ID. This can either be done by double-clicking on the layer number (the number on the left-hand side of every layer), or by selecting a layer and going to Edit > Select Group. You Layers can sever be grouped layers together by selecting them and pressing Ctrl + Shift + G or by going to Edit  > Assign New Group to Selection.

When you add files that have an alpha channel to your composition, Pdplayer will, by default, set the alpha mode for their layers to Premultiplied Mask. If you want to change this value, you can right-click on the blending and alpha mode icon on the right of the layer in the Layer Stack and choose a mode from the menu. You can also have a more advanced control over the blending and alpha modes through the Blending Panel in the Property Panel.

 

Section
Column
width10%

 

Column
width40%

Image AddedBlending and Alpha Mode icon options

Column
width40%

Image AddedBlending Panel advanced options

Column
width10%

 

 

Once you have added layers to your composition, you may want to arrange them. You can change how different layers stack over each other by dragging them in the layer stack. You can move the layers in the workspace by holding the Shift key and dragging with the left mouse button.

In Pdplayer you can decide that you want , to play only a part of a layer. By dragging the sides , go to the start or to the end of a layer you can place a until the mouse becomes a two-sided arrow, and drag. This places a Layer In Point and a Layer Out Point. When  When the player starts playing the composition, it will only show the frames between those two points of the layer. When you drag the Out Point beyond the end of the layer, Pdplayer will add a loop. Double clicking on an the In Point of a layer will reset move it to 0 and double the first frame of the sequence, resetting it to 0. Double clicking on an out point Out Point will move it to the next complete closest end of a loop.

 

Image AddedSetting the Layer In Point

 

 

Anchor
TimelineAndWorkArea
TimelineAndWorkArea

...

The Timeline and Work Area determine the composition length in frames. You can change the length of the timeline by double clicking on the value to the right of it and entering a number, or by dragging the handles on its sides. You can also choose to make the timeline fit the length of the layers in the scene, or trim it to the length of the work area. Double clicking on the side handles of the timeline will fit fits it to the length of the layers. The work area is a part of the timeline that serves as an indicator which parts of the different layers will be played. Anything outside of it will not be played. You can change the length of the work area by left clicking on the sides of it and dragging to scale it. When the work area is shorter than the timeline, you can shift it by dragging it with the middle mouse button. Double clicking on either edge of the timeline area will move it to the closest In or Out point of a layer.

...

Upon installation, the default frame rate at which Pdplayer works is 24 frames per second. You can see the current frame rate in the little box on to the left side of the Timeline. There are several ways to change this value. : First, you can right-click on the box and choose from a list of common values. You can also , or second, left-click on the box and drag, or finally, double click on the box and enter a different value.

...

The layer stack holds all the layers in the composition . It and allows you to arrange them in the timeline. You can stack them vertically so that They are stacked vertically: when you play the composition, the top layers will be in front of the bottom ones. To arrange the layers, drag them with the left mouse button .

Pdplayer allows you to play just a part of a layer by placing In and Out points for it. To do that, go to the start or to the end of a layer until the mouse becomes a two-sided arrow, and drag. When you drag the end point beyond the end of the layer, Pdplayer will add a loop. Double clicking on the In point of a layer will move it to the first frame of the sequence. Double clicking on an Out point will move it to the closest end of a loop.

as desired.

 

Anchor
save
save

Saving with Pdplayer

...

Fancy Bullets
typecircle
  • File > Save Compositions As… – Saves the whole composition as a .pdpcomp file.
  • File > Save Screen As… – Saves Pdplayer’s window as an image file.
  • File > Save Frame As… – Saves the current frame of the current layer as an image file.
  • File > Save Mask As Image... – Saves just the result in the mask area as an image file.
  • File > Save Layer As… – Pdplayer will save saves the current layer as either a sequence or a video file. If the user is saving into either MOV or AVI files and layer has audio it will be saved in the video.
  • File > Save Mask As… – As Sequence...Pdplayer will save just the result in the mask area as either a sequence or a video file. If the user is saving into either MOV or AVI file and there are layers containing audio in the composition the audio will also be saved.

 

Image Removed
Save as JPEG Sequence

 

 

When you choose to save out a JPEG Sequence you can specify the quality of the compression.:

 

Image RemovedImage Added
Save as AVI movieJPEG Sequence

 

 

When you choose to save an AVI Movie you only need to select the compression method and the quality of the clip.

 

Image Added
Save as AVI movie

 

 

Anchor
PDPexport
PDPexport

Export from Pdplayer

...

With the current version of Pdplayer you can export your composition to an After Effects script, a NUKE script and Pdplayer’s specific Pdplayer Command File (.pdpcmd). This is done by going to File > Export Composition As which will bring up the Export Composition as dialog.

 


Export Composition as dialog

...

Additional information about integrating Pdplayer with external software packages can be found in the Workflow Integration page.

The .pdpcmd file is actually a text file that contains a set of commands. Executing these commands will set up a composition the way you have saved it. The format is a very simple text format that is easy to read from and write to. This feature of Pdplayer can be used in a couple of different cases.

First, it can be used to create macros or a long set of commands to help you in your work. You can very easily set up an initial configuration for your composition for example with a certain image as a background, a resolution for the mask, frame-rate etc. Instead of trying to figure out what commands to use and write them by hand, you can just set up the composition and then export it to a .pdpcmd file.

The .pdpcmd file can also be used to enable integrating Pdplayer with third party applications that are currently not supported. Exporting your composition into .pdpcmd file it can then very easily be read by a script or a simple application and then imported into a third-party compositing application. You can also use any application that has scripting capabilities to create a .pdpcmd with the composition set the way you want it. Furthermore, you can very easily generate reference .pdpcmd files just by setting up several compositions in Pdplayer and exporting them to .pdpcmd files. You can then use these files as examples when creating your script in the third party application.

Saving your compositions in .pdpcmd files also makes it easier to quickly change the directory paths in cases where the sequences in the composition have been moved. To do that you can edit the .pdpcmd file with any text editor and use the Find and Replace feature to replace the old paths with the new ones.