Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

One of Pdplayer’s unique features is its ability to process multiple layers at the same time. Furthermore it can handle different types of layers and layers with different type of content without the need of complex procedures. All you need to do to add any kind of media content to a layer is drag and drop. Pdplayer provides several types of layers divided into normal and special layers according to their functions.

You can create layers with the Add Layer option on the File Menu, then control them with the options in the Layer Menu and Timeline Area.

 

Normal Layers

...

All these layers can be loaded in Pdplayer simply by dragging and dropping. Pdplayer will automatically add the correct type of layer according to the type of the file you have dropped.

...

typecircle

Still Image Layer – A normal layer with a single image loaded in it. This image will appear on each frame no matter how many frames there are.To add an image that is a part of a sequence as a Still Image Layer, hold the Ctrl key while dragging and dropping it into Pdplayer.

Sequence Layer – A layer containing a sequence of images

Movie Layer – A layer with a movie file loaded in it.

Audio Layer – A layer containing an audio file.

 

Special Layers

...

typecircle

...

Brush Layer – A still layer that you can draw on. Whatever is drawn on this layer will be shown on all frames. Used for putting notes in the composition.

Brush Sequence Layer – A brush layer that keeps information for each frame. This means that you can have different drawings on different frames. Used for putting notes in the composition.

Adjustment Layer – Allows you to apply color corrections to multiple layers globally. The color corrections that you make to an adjustment layer will be applied to all layers under it in the Layer Stack. If you make this layer invisible the effect of the color corrections will also be not visible.

Embedded Image Layer –Created when there is an image of any kind in the clipboard and you paste it in the composition or when you paste a frame as an Embedded Image. It behaves as a still image layer with the only difference that it can be saved within the .pdpcomp file.

Embedded Audio Layer – Created when an Audio Layer that contains a .WAV file is embedded into the composition with the Embed Layer command from the Layer menu.

Text Layer – A special kind of layer that allows you to put notes on your composition. You can control the settings for the text layer from the Text tab of the Property Panel.

Video Layer – A Pdplayer specific type of layer which allows you to insert live video footage inside Pdplayer. To do this just go to Edit > New Video Layer > and select from list of video devices that are currently attached to your computer.

Frame Buffer Layer – Very similar to the clip board layer. The only difference is that the input comes from an external source. For the moment Pdplayer supports input only from V-Ray and LightWave

 

Working with Layers

...

Once you have added layers to your composition, you may want to arrange them. You can change how different layers stack over each other by dragging them in the layer stack. It is important to know that only the part of a layer which is inside the work are will be displayed. You can further limit which parts of a layer will be shown by adding In and Out Points to it. This is done by dragging the edges of a layer. If you drag the right edge of a layer outside of it Pdplayer will automatically add a loop for this layer. Double clicking on an In Point will reset it to 0 and double clicking on an Out Point will move it to the next complete loop. Right-clicking on a layer will bring up the layer context menu which holds some additional commands.

...